This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 3 Vote(s) - 2.33 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gran Turismo - USA - UCUS98632
#31
I test this game only once long time ago and was unplayable; only 1 FPS :| ...

However, since r2684 really help my ATI card i test it again on r2707 and now game can reach 10/15 FPS. Is very slow for being playable as a car game but at least is not 1 FPS hahahaha.

When i start it to make the log file + profiler, FPS goes down to 3/4. Looks like have many graphics errors on the log; however, in game graphics are pretty well. If i check "Disable Vertex Info ..." some minor details on graphics will fix but FPS will go down; if uncheked some graphics minor bugs will show but game speed will increase a bit.

Sadly, this game also make ATI driver stop working :/ ...

Here is a short gameplay:


Attached Files
.7z   r2707x64 - GT (InfoLog+Profiler).7z (Size: 1.02 MB / Downloads: 129)
[Image: montcer.png]
Reply
#32
thankss menn
Reply
#33
If load bad save(attched),jpcsp would
Code:
00:43:23 ERROR   memory - PDI:00000020 - read32 - Invalid memory address: 0x00000000 PC=0x08A4BAF0
Real PSP would show
Code:
Load failed due to data being corrupted.
Do you wish to retry ?
Choosing "NO" will cause your data to be lost
I have enabled "handle SAVEDATA in crypto mode"
Attach hle.sceUtility debug log and JPCSP trace log.


Attached Files
.zip   UCUS98632-GAMEDAT.zip (Size: 55.83 KB / Downloads: 111)
.zip   jpcsptracelog.zip (Size: 1.33 KB / Downloads: 101)
.txt   3376log.txt (Size: 39.79 KB / Downloads: 86)
Reply
#34
last good
https://github.com/jpcsp/jpcsp/commit/ad...f312766bea

first bad
https://github.com/jpcsp/jpcsp/commit/82...21af48a529

It mean
https://github.com/jpcsp/jpcsp/commit/82...21af48a529 has problem
attach 25532f9 and both scefont debug log

WARN hle.SysMemUserForUser - PDI:00000020 - malloc cannot allocate partition=2, name='PDI:ABLOCK', type=PSP_SMEM_Low, size=0x6A0000, addr=0x00000000, maxFreeMem=0x4C2100, totalFreeMem=0xA19900


Attached Files
.7z   ad1c9c2-good-log.7z (Size: 145.16 KB / Downloads: 124)
.7z   8295722-bad-log.7z (Size: 105.49 KB / Downloads: 104)
.7z   25532f9-bad-log.7z (Size: 150.35 KB / Downloads: 106)
Reply
#35
(04-15-2017, 10:20 AM)sum2012 Wrote: last good
https://github.com/jpcsp/jpcsp/commit/ad...f312766bea

first bad
https://github.com/jpcsp/jpcsp/commit/82...21af48a529

It mean
https://github.com/jpcsp/jpcsp/commit/82...21af48a529 has problem
attach 25532f9 and both scefont debug log

WARN hle.SysMemUserForUser - PDI:00000020 - malloc cannot allocate partition=2, name='PDI:ABLOCK', type=PSP_SMEM_Low, size=0x6A0000, addr=0x00000000, maxFreeMem=0x4C2100, totalFreeMem=0xA19900
I improved sceFontFlush by comparing with the results of a libfont.prx from a real PSP. Does it help here?
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply
#36
92a7d29 version
now jpcsp hang after second tap
Not sure compile debug can record something useful
log:
https://drive.google.com/file/d/0B3OaSde...sp=sharing
(04-17-2017, 09:52 AM)gid15 Wrote: I improved sceFontFlush by comparing with the results of a libfont.prx from a real PSP. Does it help here?
Reply
#37
(04-17-2017, 01:18 PM)sum2012 Wrote: now jpcsp hang after second tap
Not sure compile debug can record something useful
log:
https://drive.google.com/file/d/0B3OaSde...sp=sharing
Hmmm, maybe could it be related to the Atrac3 decoding when reaching the end of an audio track?
Could you please create an INFO log with the following line added to LogSettings.xml:
Code:
<logger name='hle.sceAtrac3plus'> <level value='debug' /> </logger>
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply
#38
When jpcsp hang,the log still record
Code:
06:15:42 DEBUG hle.sceAtrac3plus - PDI:00000015 - sceAtracDecodeData returning 0x0
06:15:42 DEBUG hle.sceAtrac3plus - PDI:00000013 - sceAtracGetRemainFrame atID=0x0, remainFramesAddr=0x09F09240
06:15:42 DEBUG hle.sceAtrac3plus - PDI:00000013 - sceAtracGetRemainFrame returning 87, AtracID[id=0, inputBuffer=pspFileBuffer(addr=0x08E9F3C0, maxSize=0x20000, currentSize=0xFCD8, readPosition=0x182F0, writePosition=0x7FC8, filePosition=0x3C7FC8, fileMaxSize=0x3C7FC8), channels=2, outputChannels=2]
06:15:42 DEBUG hle.sceAtrac3plus - PDI:00000013 - sceAtracGetRemainFrame returning 0x0
(04-17-2017, 05:31 PM)gid15 Wrote:
(04-17-2017, 01:18 PM)sum2012 Wrote: now jpcsp hang after second tap
Not sure compile debug can record something useful
log:
https://drive.google.com/file/d/0B3OaSde...sp=sharing
Hmmm, maybe could it be related to the Atrac3 decoding when reaching the end of an audio track?
Could you please create an INFO log with the following line added to LogSettings.xml:
Code:
<logger name='hle.sceAtrac3plus'> <level value='debug' /> </logger>


Attached Files
.7z   92a7d29-sceAtrac3plus-log.7z (Size: 248.89 KB / Downloads: 121)
Reply
#39
(04-17-2017, 10:20 PM)sum2012 Wrote: When jpcsp hang,the log still record
Code:
06:15:42 DEBUG hle.sceAtrac3plus - PDI:00000015 - sceAtracDecodeData returning 0x0
06:15:42 DEBUG hle.sceAtrac3plus - PDI:00000013 - sceAtracGetRemainFrame atID=0x0, remainFramesAddr=0x09F09240
06:15:42 DEBUG hle.sceAtrac3plus - PDI:00000013 - sceAtracGetRemainFrame returning 87, AtracID[id=0, inputBuffer=pspFileBuffer(addr=0x08E9F3C0, maxSize=0x20000, currentSize=0xFCD8, readPosition=0x182F0, writePosition=0x7FC8, filePosition=0x3C7FC8, fileMaxSize=0x3C7FC8), channels=2, outputChannels=2]
06:15:42 DEBUG hle.sceAtrac3plus - PDI:00000013 - sceAtracGetRemainFrame returning 0x0
(04-17-2017, 05:31 PM)gid15 Wrote:
(04-17-2017, 01:18 PM)sum2012 Wrote: now jpcsp hang after second tap
Not sure compile debug can record something useful
log:
https://drive.google.com/file/d/0B3OaSde...sp=sharing
Hmmm, maybe could it be related to the Atrac3 decoding when reaching the end of an audio track?
Could you please create an INFO log with the following line added to LogSettings.xml:
Code:
<logger name='hle.sceAtrac3plus'> <level value='debug' /> </logger>
I have found a small compatibility issue in sceAtracDecodeData and fixed it in 3fb6e24. Does it help here?
Always include a complete log file at INFO level in your reports. Thanks! How to post a log
Reply
#40
67c1f67 version
It still hang
(04-19-2017, 04:23 PM)gid15 Wrote: I have found a small compatibility issue in sceAtracDecodeData and fixed it in 3fb6e24. Does it help here?


Attached Files
.7z   67c1f67_log.7z (Size: 258.62 KB / Downloads: 111)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)